правильная установка и настройка OpenJDK и Р

Я относительно новым на Ubuntu, поэтому я не знаю много команд, которые, вероятно, стала стандартом для многих из вас. Я пытаюсь установить R и С это необходимых зависимостей Java, чтобы установить, например, руководство JGR, rjava, и т. д. Я прочитал довольно много инструкций, но почему-то я должен сделать СТГ неправильно. Вот это состояние R и Java:

Р --версия

R версия 2.14.1 (2011-12-22)
Авторское право (c) Фонд 2011 года R для статистических вычислений
ИСБН 3-900051-07-0
Платформа: x86_64 с-ПК-Линукс-гну (64-разрядная)

Java-версия

Java версия "1.6.0_23"
Во время выполнения OpenJDK в окружающей среде (IcedTea6 1.11 предзаказ) (6b23~pre11-0ubuntu1.11.10.1)
Пакеты OpenJDK 64-разрядный сервер VM (сборка 20.0-В11, смешанный режим)

Р javareconf УМК 

Java-интерпретатор : /usr/Бен/Ява
Версия Java : 1.6.0_23
Ява домашнем каталоге : /usr/lib в/в jvm/java-машины 6-пакеты OpenJDK/JRE и
Компилятор Java : /usr/Бен/и javac
Ява заголовки ген.: /usr/Бен/javah
Инструмент архива Java: /usr/Бен/опарника
Библиотека Java путь: /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/server:/usr/lib/jvm/java-6-openjdk/jre/lib/amd64:/usr/lib/jvm/java-6-openjdk/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib/jni:/lib:/usr/lib
JNI, у флагов компоновщика : -Л в/usr/lib в/в jvm/java-машины 6-пакеты OpenJDK/JRE, в каталоге/lib/amd64 на сервер -л в/usr/lib в/в jvm/java-машины 6-пакеты OpenJDK/JRE, в каталоге/lib/amd64 на -Л в/usr/lib в/в jvm/java-машины 6-пакеты OpenJDK/JRE и/..в/lib/amd64 на -Л в/usr/Java, С/пакеты, в/lib/amd64 на -Л в/usr/lib в/JNI, У -Л/Либ -л в/usr/lib в -ljvm
JNI, у флагов СРР : 

Но когда я пытаюсь установить 'JavaGD' в R, который является зависимостью для руководство JGR я получаю:

...
проверка поддержки Java в р... присутствуют:
переводчик : '/usr/Бен/Ява'
флаги ЧГК : "
Ява библиотеки : -Л в/usr/lib в/в jvm/java-машины 6-пакеты OpenJDK/JRE, в каталоге/lib/amd64 на сервер -л в/usr/lib в/в jvm/java-машины 6-пакеты OpenJDK/JRE, в каталоге/lib/amd64 на -Л в/usr/lib в/в jvm/java-машины 6-пакеты OpenJDK/JRE и/..в/lib/amd64 на -Л в/usr/Java, С/пакеты, в/lib/amd64 на -Л в/usr/lib в/JNI, У -Л/Либ -л в/usr/lib в -ljvm'
настроить: ошибка: один или более конфигурации в Java переменные не установлены.
Убедитесь, Р настроена с полной поддержкой Java (включая JDK). Запустить
Р javareconf УМК 
как корень, чтобы добавить поддержку Java в р.
...

Любая помощь будет высоко оценили. Спасибо!

+884
liza lobo 20 апр. 2019 г., 06:05:21
37 ответов

Я новичок в сообществе Ubuntu, но это как закладка в моем браузере. Вы можете увидеть, если это помогает.

http://www.ehow.com/how_5962897_create-bin-file-ubuntu.html

+971
REDSK 03 февр. '09 в 4:24

Когда я поставил углы, чтобы выявить рабочие области/окна, он перестает работать после нескольких перезагрузок. Почему? Кроме того, избранный Мой экран входа в систему длится в течение 1 секунды во время входа в систему и возвращается к текущему обои. Почему?

+967
Tynika Scott 16 мая 2015 г., 23:26:53
Другие ответы

Связанные вопросы


Похожие вопросы

Свежие, программа Adobe AIR приложение, это один я использую:


(источник: webresourcesdepot.com)

+881
jettam 10 мар. 2013 г., 17:54:11

Как вы установите драйвер ? Можно наверное просто удалить или удалить/переместить файл xorg.конф

Загрузиться в режиме восстановления, запустите корневой оболочки. Вы будете в командной строке без графического интерфейса

судо МВ в /etc/Х11/файл xorg.конф в /etc/Х11/файл xorg.конф.АТИ

выход корневой оболочки, и продолжить с нормальной загрузке

выход 
+841
ajavalera 9 июл. 2014 г., 01:39:11

.. одна простая задача -

Запустите терминал и введите в "судо Наутилус" ( без кавычек )

Теперь, перейдите в usr/доли/приложения/ ( нажмите файловую систему, чтобы видеть папку usr )..

Вы увидите целую кучу приложений, в зависимости от того, что вы не хотите видеть в панели GNOME вы перетащите его оттуда в другое место ( будь то рабочий стол, папки и т. д.. Не удаляйте его )..

Будем работать ;)

+831
Braedon Rudolph 22 февр. 2011 г., 07:30:16

Назад в день, там был захват. Это были сложные, несколько неудобным интерфейсом, но все было настраиваемым и, как правило, это сработало. Затем он был заброшен.

Теперь есть всевозможные инструменты, но найти один, который имеет достаточные возможности настройки (пожалуйста, позвольте мне представить командной строки хромает ... вот и все, что я прошу!) была многолетней фрустрации. Я думаю, я понимаю желание сохранить вещи простыми, но наверняка кто-то еще хочет использовать "--пресет экстрим". Рукоятка также была аккуратной системе для обработки специальных символов в названия треков (содрал любой Сигур группы или альбомы múm?) что я не видел в других инструментах.

Вот те, которые я пробовал:

  • АБВГД — больно "уй", раздражает и сложно заниматься, когда конвертер не имеет сведения, но это настраивается и в целом это лучшее из много (удивительно)
  • порознь — не можем настроить хромой вариантов, не действует в Unix-м Вт.Р.Т. параметры конфигурации (например, дорожки с ведущими слеши не является абсолютным)
  • ripperx — более настраиваемый, что позволяет "лишние" варианты хромает, запутанным пользовательского интерфейса, документации устаревшим способом
  • звук-соковыжималка — Убунту врачи предупреждают людей из-за некоторых проблем с GStreamer
  • rubyripper — попытался это и ненавидели его по причинам, которые я сейчас не могу вспомнить, да и не в репозиториях, во всяком случае
  • Банши — неадекватное варианта конфигурации, убогого в iTunes-как пользовательский интерфейс (я наверное в меньшинстве, что посмотреть), вялым и раздутой

Я не пробовала средства KDE.

Моя основная проблема что я живу в прошлом здесь? Есть некоторые удивительные Потрошитель/энкодера в репозиторий, который ловко уклоняется от поисков через синаптическую?

+828
P Murtha 4 апр. 2017 г., 20:01:25

Обновление думаю, что это может быть потому что у меня есть некоторые проблемы загрузки с ЛВМ - прежнему нуждается в любой помощи кто может предложить - даже просто указатель или два о том, где искать буду признателен.

Одна из моих машин 11.10 не загружается - и я в недоумении, почему и что с этим делать: я даже не уверен, если это программная или аппаратная проблема.

Машина не рухнет и останется под контроль программного обеспечения на все времена (например, Нум Лок работает всегда, ПНО+альт+дель приведет к упорядоченному перезагрузка), но загрузки не полной: я получаю "/сценарии/инит-дно ... делать", несколько минут подождать, потом сделать сообщения как "SCSI-устройств: убийство запросы за мертвого очереди", затем сообщение, чтобы сказать один из моих SCSI ленточные накопители прилагается затем, опять после короткого ожидания, некоторые сообщения о том, как "водораздел Ш-с 'на/sbin/ЛВМ/vgscan; на /sbin/д vgchan например, вместо строки а-г'" был расторгнут с сигналом 9, затем "Готово", а потом ничего - т. е. машина просто сидит там, до сих пор под программным контролем, но видимо ничего не делают.

Нажав сочетание клавиш Ctrl+альт+del выдает сообщение, что алса-главное процесс и Плимут-выскочка-моста были приостановлены до упорядоченного перезагрузка начинается.

Если я использую загрузочный компакт-диск, файловая система, кажется, существует неповрежденный.

Я знаю, что это немного расплывчато, но любая помощь с этим было бы очень кстати.

+815
hak 27 авг. 2017 г., 07:10:00

Есть инструмент, который просматривать страницы в браузере, это называется doccentral. Вы можете установить его с помощью следующей команды:

 судо apt-получить установку док-центральный

Затем откройте терминал и введите doccentral пакет-название, например

 doccentral питона

Что привело вас в браузере по умолчанию с содержимым, такие как этот.

enter image description here

+811
Jonas Michel 2 мар. 2016 г., 06:31:40

Если у вас есть две звуковых устройств, возможно, пульс пытается использовать микрофон от первой карты (-с, 0) и не второе (-с 1-Ваши творческие). Установить и запустить pavucontrol и при попытке записать, проверьте, какое устройство используется. Если неправильный, измените его.

+777
The Rocketeer 28 мая 2013 г., 12:49:22

У меня есть общая папка Samba на рабочем столе. Есть ли способ, чтобы отключить в Ubuntu общую папку запрос пароля при доступе из окна?.

+745
pansapiens 22 мар. 2016 г., 00:47:11

Не легко, быстро приложения используют много вещей, которые являются уникальными для настольных Linux чтобы сделать ваше приложение работать и интегрироваться лучше.

+744
topranks 6 апр. 2016 г., 08:09:35

Я устанавливаю залет с судо apt-получить установку. Эта ошибка у меня:

...
Обработка триггеров для bamfdaemon ...
Восстановление /usr/доли/приложения/фумб.индекс...
Обработка триггеры для desktop-файл-утилиты ...
Обработка триггеры для GNOME-меню ...
Обработка триггеров для режим hicolor-значок-тема ...
Установка в VirtualBox (4.1.18-для dfsg-1ubuntu1.2) ...
 * Остановка модулей ядра VirtualBox и [ ОК ] 
 * Начиная с модулей ядра VirtualBox и 
 * Нет подходящего модуля для запуска ядра нашли [не]
ссылаться-ру.д: инициализации в VirtualBox, акция "перезагрузка" провалилась.
Настройка бродяга (1.0.3-1) ...
Обработка триггеры для ureadahead ...
Установка в VirtualBox-переходный (4.1.18-для dfsg-1ubuntu1.2) ...
Загрузки новый пакет 4.1.18 файлов формате HTML...
Первая установка: проверка всех ядер...
Дом только для 3.8.0-030800-универсальный
Здание начального модуля для 3.8.0-030800-универсальный
Ошибка (переходный Аппорт): ядра пакета Linux-заголовков-3.8.0-030800-универсальный не поддерживается
Ошибка! Плохое состояние вернуть для сборки модуля ядра: 3.8.0-030800-универсальный (x86_64 с)
Консультации /ВАР/Либ/переходный/строки/4.1.18/построить/сделать.журнал для получения дополнительной информации.
 * Остановка модулей ядра VirtualBox и [ ОК ] 
 * Начиная с модулей ядра VirtualBox и 
 * Нет подходящего модуля для запуска ядра нашли [не]
ссылаться-ру.д: инициализации в VirtualBox, акция "перезагрузка" провалилась.
Установка в virtualbox-qt в (4.1.18-для dfsg-1ubuntu1.2) ...
Обработка триггеров для меню ...

В Ubuntu 12.10

$ команды uname -а
С Linux 3.8.0-030800-универсальный #201302181935 СМП Вт фев 19 00:36:19 по UTC 2013 x86_64 с архитектуру x86_64 архитектуру x86_64 GNU/Линукс
+724
okmttdhr 13 февр. 2018 г., 07:01:28

Может быть, этим и объясняется магия:

директорию типа drwxr-XR-х

переводится в

(права доступа rwx)(р-х) (р-х)

переводится в

(421) (401) (401)

переводится в

755

Так что ответ

судо команду chmod 755 /usr/местные/Ява
+699
Hannes Driessen 26 апр. 2013 г., 05:06:45

Я смотрю на покупку MarbleBlast золото от крутящего момента и игра под названием Orbz и одним из требований является на glibc2.2+

Я сделал небольшое исследование в этом вопросе и заметил, что Ubuntu использует eglibc,и что glibc еще в версии 2.11 в чистой установки. Однако учитывая, что библиотека C является очень важной частью операционной системы, я держался от этого.

Это безопасно, не портя ОС? и если да, то как бы я пойти об этом?

+648
Jerin T George 17 окт. 2012 г., 07:31:43

По крайней мере с моей стороны, я считаю, что это решаемо.

Недавно, водитель Я много читал о - 173.14.35 - был выпущен означает, что я могу открыть и установить с помощью apt-получить. По ссылке в оригинале вопрос приводит к объявлению, что Nvidia-173 на точное-предложил обновлен до ХХХ.ХХ.35, и так это дело, следуя указаниям на этой странице указаны: https://wiki.ubuntu.com/Testing/EnableProposed

Так как это довольно новое исправление, я не буду гарантировать, что это работает для всех версий видеокарт Nvidia под Ubuntu 12.04. Но за мои деньги это было намного выгоднее даунгрейд xorg или отката к старой ОС.

+647
Khovanov 4 мар. 2010 г., 12:19:43

Я сохранил привязанность после того, как я открыл файл->открыть Сохраненные сообщения... меню в Thunderbird.

+645
tindleaj 10 мая 2013 г., 01:22:07

Что это значит, я не могу установить Хаскелл? Я только что повышен до Нэтти, это причина?

Как вы можете видеть на скриншоте, я получаю эту проблему в программе Центра:

enter image description here

Следующие пакеты имеют неудовлетворенные зависимости:

Хаскелл-платформа: зависит: ghc6 (< 6.12.1+), но 6.12.3-1ubuntu7 должен быть установлен
 Зависит: libghc6-цги-Дэв (>= 3001.1.7.2) но 3001.1.7.2-1build1 должен быть установлен
 Зависит: libghc6-ИУП-Дэв (< 5.4.2.2+) но 5.4.2.2-2build2 должен быть установлен
 Зависит: libghc6-перенасыщение-Дэв (< 2.1.2.1+) но 2.1.2.1-1build1 должен быть установлен
 Зависит: libghc6-Хаскелл-КГД-Дев (< 1.0.1.3+) но 1.0.1.3-2build1 должен быть установлен
 Зависит: libghc6-в HTML-Дев (< 1.0.1.2+) но 1.0.1.2-3build2 должен быть установлен
 Зависит: libghc6-H единичных-Дэв (< 1.2.2.1+) но 1.2.2.1-2build2 должен быть установлен
 Зависит: libghc6-МТЛ-Дэв (< 1.1.0.2+) но 1.1.0.2-10build2 должен быть установлен
 Зависит: libghc6-сеть-Дэв (< 2.2.1.7+) но 2.2.1.7-1build2 должен быть установлен
 Зависит: libghc6-поддержка OpenGL-Дэв (< 2.2.3.0+) но 2.2.3.0-2build2 должен быть установлен
 Зависит: libghc6-параллельно-Дэв (< 2.2.0.1+) но 2.2.0.1-1build1 должен быть установлен
 Зависит: libghc6-parsec2-Дэв (< 2.1.0.1+) но 2.1.0.1-2build2 должен быть установлен
 Зависит: libghc6-quickcheck2-Дэв (< 2.1.0.3+) но 2.1.0.3-1build2 должен быть установлен
 Зависит: libghc6-регулярное-база-Дэв (< 0.93.1+) но 0.93.1-8build1 должен быть установлен
 Зависит: libghc6-регулярное-совместимости-Дева (< 0.92+) но 0.92-6build2 должен быть установлен
 Зависит: libghc6-регулярных выражений-POSIX-Дэв (< 0.94.1+) но 0.94.1-2build1 должен быть установлен
 Зависит: libghc6-СТМ-Дэв (< 2.1.1.2+) но 2.1.1.2-5build2 должен быть установлен
 Зависит: libghc6-в XHTML-Дэв (>= 3000.2.0.1) но 3000.2.0.1-6build2 должен быть установлен
 Зависит: libghc6-с zlib-Дэв (< 0.5.2.0+) но 0.5.2.0-4build2 должен быть установлен
 Зависит: libghc6-и HTTP-Дэв (>= 40000009) но 40000009-2build1 должен быть установлен
 Зависит: libghc6-deepseq-Дэв (< 1.1.0.0+) но 1.1.0.0-2build1 должен быть установлен
 Зависит от: Алекс (< 2.3.3+) но 2.3.3-1 должен быть установлен
 Зависит: счастлив (< 1.18.4-2+), но 1.18.4-2 должен быть установлен
 Зависит: пикша, но это виртуальный пакет
+587
Fabio Cardoso Nobre 29 июл. 2015 г., 07:48:24

У меня 5 разделов, из которых C: - раздел Windows, который имеет ничего, кроме установленной ОС Windows. Другие диски, содержащие важные файлы. Так что будем устанавливать Ubuntu на диск C: и замена Windows, удаление файлов с других дисков ?

+533
Paige O 19 янв. 2020 г., 21:48:52

Моя Ubuntu 10.10 просто упал, вероятно, из-за аппаратной ошибки (и в итоге я получаю ошибки, как неизвестная файловая система ..... жратва> .., и он пошел к жратве консоли, прежде чем я мог предпринять любое другое действие).

Я переустановил ту же версию с USB-накопителя. У меня Ubuntu установленная с в ext4 файловую систему и я тоже имею ту же файловую систему в одного жесткого диска на другой диск.

Когда я пытаюсь получить доступ к моей предыдущей файловой системы, я получаю ошибки:

Ошибка монтажа: крепление: неверный тип ФС, плохой вариант, плохой суперблок на /dev/sda6,
 отсутствует кодовая страница или программа-помощник, или другая ошибка
 В некоторых случаях полезная информация найдена в syslog - попробуйте
 команда dmesg | хвост или так

У меня были некоторые важные файлы в предыдущем томе, я не знаю, как получить их.

И каковы шансы, что я получу тот же результат (аппаратная ошибка)? Пожалуйста, помогите мне!

+506
Mina11 25 окт. 2018 г., 06:45:53

Как сказал Эрик, вы можете отключить Бебу на узле:

 $ Бебу-отключить

После запуска SSH в, вы можете отключиться от текущего сеанса, но и поддерживать местных оболочки .

Вы можете войти по SSH и запустить bash вместо Бебу:

 $ СШ -Т <имя_узла> Баш

И можно также принять, что постоянные и влиять на все ваши сеансы по SSH в Ubuntu/Бебу хозяев (где Бебу > 4.0), установив LC_BYOBU=0 в вашем ~/.bashrc следующее:

 $ Эхо "экспорт LC_BYOBU=0" >> ~/.bashrc следующее
 $ . ~/.bashrc следующее
 $ СШ <имя_узла>
+475
Julie Aronson 16 авг. 2014 г., 12:36:05

У меня проблема с Убунту 11.10, этот вопрос описано в следующей ссылке: жесткий диск значок исчезает после установки

После рытья и копания я нашел проблему. Это проблемы с перегородкой в ext4, потому что я могу монтировать разделы NTFS без каких-либо проблем.

Вот подробности.

в /var/журнал/системный журнал

29 декабря 22:06:32 МС-компания Lenovo-G550 в нтфс-3г[3240]: версия 2011.4.12 АР.4 внешний предохранитель 28

29 декабря 22:06:32 МС-компания Lenovo-G550 в нтфс-3г[3240]: монтируется на /dev/sda2 (Чтение-запись, метка "тест", для NTFS 3.1)

29 декабря 22:06:32 МС-компания Lenovo-G550 в нтфс-3г[3240]: параметры командной строки: РВ,с nosuid,nodev,uhelper=udisks,uid номер=1002,гид=1002,разделах=0077,fmask=0177

29 декабря 22:06:32 МС-компания Lenovo-G550 в нтфс-3г[3240]: установите параметры: rw,nosuid,nodev,uhelper=udisks,allow_other,nonempty,relatime,fsname=/dev/sda2,blkdev,blksize=4096,default_permissions

29 декабря 22:06:32 МС-компания Lenovo-G550 в нтфс-3г[3240]: глобальной собственности и разрешения насильственных, тип конфигурации 7

29 декабря 22:06:38 МС-компания Lenovo-G550 в ядре: [ 45.141025] userif-2: отправлен событие связи.

29 декабря 22:06:38 МС-компания Lenovo-G550 в ядре: [ 401.741884] в ext4-ЧЗ (sda8): смонтированную файловую систему с упорядоченной режиме данных. ОПЦ: (нуль)

корень@МС-компания Lenovo-G550 в:~# горы |хвост -2

на /dev/sda2 на /СМИ/испытания типа fuseblk (РВ,с nosuid,nodev,allow_other,блоку=4096,default_permissions)

на /dev/sda8 на /СМИ/тип Misc_ в ext4 (RW,то с nosuid,nodev,uhelper=udisks)

корень@МС-компания Lenovo-G550 в:~# LS-Ла - /СМИ/ --- итого 16

директорию типа drwxr-XR-х 4 корень корень 4096 2011-12-29 22:15 .

директорию типа drwxr-XR-х 24 корень корень 4096 2011-12-11 22:30 ..

drwx------ 17 мс МС 4096 2011-12-22 21:59 накл

drwx------ 1 АБВ АБВ 4096 2011-12-29 20:31 тест

Мой вопрос Как монтировать как ext4 так же, как NTFS ?

+377
TimKa 17 авг. 2015 г., 06:19:12

Некоторые апплеты доступны для гном-панели 3, но не все. https://launchpad.net/gnome-applets

Некоторые апплеты не были портированы из комплекта библиотек GTK2 на Gtk3 еще. Кажется индикатор-апплет в ходе портированы. https://bugs.launchpad.net/indicator-applet/+ошибка/724369

+365
lgjmac 29 сент. 2018 г., 00:16:30

В ТТФ-Убунту-семейство шрифтов пакет устанавливает следующие текстовые файлы:

/usr/доли/шрифты/шрифты TrueType/Убунту-купел-семья/Убунту-Б. ТТФ
/usr/доли/шрифты/шрифты TrueType/Убунту-купел-семья/Убунту-Би.ТТФ
/usr/доли/шрифты/шрифты TrueType/Убунту-купел-семья/Убунту-И. ТТФ
/usr/доли/шрифты/шрифты TrueType/Убунту-купел-семья/Убунту-Р. ТТФ

Возьми те и тащут их на другие установки. Либо использовать просмотрщик шрифтов, чтобы установить их под своим пользователем или ударить их в /usr/доли/шрифты/шрифты TrueType/ под аналогичную структуру, как было в Ubuntu.

Примечание: шрифт под лицензией Убунту шрифт. Если вы планируете распространяйте ее, прочитал первый файл лицензии:

zcat выступает /usr/share/doc/ttf-ubuntu-font-family/LICENCE-FAQ.txt.gz | менее
+360
mv9k 28 мая 2016 г., 21:08:36

Поэтому я просто решил удаления Wubi из D:\ и просто скачать ISO-образ 32-и создание загрузочного USB-диска, следуя инструкциям из Как создать загрузочную флешку в Windows.

Я просто проверял и работало нормально. Единственное, что я заметил, что моя сеть не работает (проводной и беспроводной), я подумала, что, наверное, это только живой ОС, которое было предварительно загружено и конфиг пока не установлен, но это моя теория. Я просто, наверное, попробовать и установить пакет ISO и проверить все от него.

+350
Marcel de Roode 20 окт. 2016 г., 06:41:18

Я сталкивался с этой проблемой пару раз при создании сервера сборка с ключом аутентификации.

Мне было интересно, если кто-то имеет опыт в этом. У меня есть пару ключей для моих текущих пользователей, которые могут подключаться к разным машинам. Пусть говорят машина1 и машина2. Я расклеил мой открытый ключ в соответствующие authorized_keys файл. Первый я назвал первый ключ id_rsa и второй ключ Бендер.

Когда я пытаюсь подключиться к Бендеру я получаю следующее выход с моего подробного соединение SSH

debug1: SSH2_MSG_NEWKEYS послал
debug1: ожидая SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS получил
debug1: SSH2_MSG_SERVICE_REQUEST послал
debug1: SSH2_MSG_SERVICE_ACCEPT получил
debug1: проверки подлинности, который может продолжаться: открытый ключ
debug1: Следующий способ проверки подлинности: открытый ключ
debug1: попытка закрытого ключа: /дома/профан/.СШ/.СШ/идентичности
debug1: попытка закрытого ключа: /дома/профан/.СШ/.по SSH/id_rsa
debug1: попытка закрытого ключа: /дома/профан/.по SSH/id_dsa, который находится
debug1: нет больше методов проверки подлинности, чтобы попробовать.
Отказано в доступе (открытый ключ).

Он предлагает только ключ id_rsa, как вы можете видеть выше. Это правильно? Если это так, почему? Как я могу получить его, чтобы предложить больше ключей? Я знаю, что это проблема, которую я вижу периодически, потому что дома у меня есть несколько ключей без особых проблем.

Я также хотел бы получить обзор о том, как паб и частная ключи взаимодействовать с клиентом и сервером. Я думал, что у меня довольно неплохая идея, но, видимо, я что-то упускаю.

Пожалуйста, и спасибо.

+343
david dermott 31 июл. 2017 г., 18:17:28

Вино позволяет выполнить .программа exe, если вы выбираете вино в качестве программы по умолчанию .исполняемые файлы от Наутилус, открыть .EXE файл через "открыть с помощью другой программы" и выберите вино или вы выполняете вино file.exe от терминала.

+319
Rams Ramirez 8 июл. 2015 г., 12:48:22

Это должно сделать это:

судо apt-получить установку с Compiz-фьюжн-Плагины-главный менеджер-фьюжн-Плагины-дополнительные
+309
Sanjit Sharma 4 нояб. 2012 г., 16:51:34

В мой .профиль у меня есть следующие команды

[[ -s "на$дома/.РВМ/скрипты/РВМ" ]] && источник "$дома/.РВМ/скрипты/РВМ"

Прямо сейчас, чтобы получить желаемое поведение у меня к тип источника ~/.профиль в терминале. Я хотел бы, чтобы это было автоматически (так как это .профиль), но это не так. Любые идеи?

Мой .профиль выполняется при входе (проверял с экспорт из Foo=бар).

+301
Tim Cooley 28 июл. 2012 г., 14:31:10

Другой вариант-сделать выделенный раздел для grub2 (в отличие от выделенного /загрузочный раздел монтирования при загрузке), см. Герман учебник.

Преимущество: вы можете снять/установить операционку по желанию.

Недостаток: вам нужно изменить харчи.cfg в файл вручную. Чтобы избежать необходимости делать это после каждого обновления ядра я рекомендую использовать ссылку на ядра изображения, а не сам образ ядра, например использовать что-то вроде

для Linux /vmlinuz root=Ваш идентификатор UUID=3e4xxxxx-027b-407с-ba1a-хххххххх РО тихий всплеск

не

в Linux файл /boot/vmlinuz-2.6.35-28-родовой корень=идентификатор UUID=3e4xxxxx-027b-407с-ba1a-хххххххх РО тихий всплеск 

Для получения дополнительной информации об использовании символических ссылок вместо полных путей для ядра снимков смотрите здесь.

Disadvantage2 (спасибо psusi): при установке новой операционной системы убедитесь, что вы не установите его жратву изображения в MBR. Установить его без жратвы, а затем вручную изменить харчи.cfg в файл для включения новой ОС.

+221
Michael Ecklund 15 окт. 2011 г., 20:41:43

Попробуйте сделать это в вашем терминале:

суда нано /и т. д./По умолчанию/жратву

Искать:

GRUB_CMDLINE_LINUX_DEFAULT="тихий плеск"

Тоже изменить :

GRUB_CMDLINE_LINUX_DEFAULT="тихий"

И обновление жратвы:

обновление-жратва судо 

И посмотреть, если это помогает, если не пост уот происходит.

+216
Russ Dill 17 февр. 2012 г., 03:41:06

Я в настоящее время работает Ubuntu 12.04 и пока я был с помощью Google облако печати, чтобы печатать вещи на моем нетбуке под управлением Windows 7 начальная до Ubuntu принтер. В последнее время я заметил, что произошла ошибка, что почему-то просит меня, чтобы вместе войти в мою электронную почту и пароль, когда я нажимаю на сообщение воздушный шарик от Chrome ничего не загружает.

Я не получаю эту ошибку на Windows, так что случилось?? Я пробовал вход и выход, но это не сработало. Как я могу заставить его работать снова?

Или есть другой способ совместного использования принтера из Ubuntu в Windows 7 начальная (нет ИПП по одной)

Спасибо.

+211
Yeung Gerbz 15 мая 2017 г., 16:14:59

После сегодняшнего обновления 12.04 до последней версии ядра Linux и Chrome до версии 20 камеру (творческая жить! Кэм Sicialize HD) и ведет себя странно, когда я на странице Gmail в Chrome: он мигает и сам браузер зависает время от времени на несколько секунд. Я не знаю, что влияет на которая (т. е. обновлений Linux неприятностей Chrome или наоборот) и до сих пор не может найти решение. Очевидно, однако, что описанное выше поведение вызвано плагин поговорить в Chrome - когда я закрываю вкладку Gmail в браузере возвращается к нормальной жизни. Любые идеи, что это такое и как исправить эту проблему?

+191
embeck 11 февр. 2013 г., 17:53:48

В стороне от места, предназначенного для root, см. Мой другой ответ здесь. Короче, что серия ВН файловых систем пространства резервов на индексный дескриптор таблицы в формат времени, который с настройками по умолчанию, составляет 2 МБ каждый 128 Мб дискового пространства.

+162
yini 26 мая 2011 г., 08:17:53

Я столкнулся странная проблема, что мои системные часы сбрасываются на 1 января 2007 в 0:00. Кто-нибудь может помочь мне исправить это?

В BIOS показывают то же время. Что я должен делать?

+135
Rama Krishna jada 11 окт. 2017 г., 21:30:20

Вы знаете, сетевых подключений что-то в Linux-сообществе активно двигался, чтобы дать больше поддержки. Вы можете хотеть идти вперед и обновить, если возможно, и любые сетевые проблемы могут решить сами.

У меня есть несколько опытом ноутбуки, что бы не подключаться к WiFi на 9.10, но после обновления до 10.04 или 10.10 беспроводной работал.

Не поможет ваш точный вопрос, но это может сделать ненужные на ваш вопрос.

+105
Jacob Eggers 6 сент. 2016 г., 13:42:20

Вы нажмите клавишу Tab для перемещения в этих диалоговых окнах туи. Один раз <ОК> будет выделен, нажмите клавишу Enter.

+98
user25369 1 июл. 2010 г., 05:27:56

Я заметил в единстве, что в меню, кажется, быть "перенаправлены" в еще одно место за пределами моего графического интерфейса приложения, на панели в верхней части экрана.

Я думаю, что вы имеете в виду поведение по умолчанию в Unity. Unity использует глобальное меню (тот, который вы видите вверху) похоже на то, что видно на OSX.

Unity app menu in action.

Если вы хотите, это может быть отключен в вашем приложении, но я думаю, что не очень рекомендуется: всем, кто использует Unity будет ожидать меню не на окно, но на самом верху.

О поле ввода я бы предположил, что это может быть проблема с темой для Ubuntu. Чтобы проверить это, попробуйте сменить тему оформления в Ubuntu (в разделе "Настройки системы" -> "внешний вид") и посмотреть, если поле остается прежним.

Редактировать

Мне было любопытно, и глядя на код похоже, что проблема в вашем приложении.Это , кажется, чтобы исправить проблему (я не могу ввести символ новой строки в той коробке, но я не могу сказать, нормально ли это или баг). Эти значения (100, 200) были отобраны случайным образом, так что это может не быть лучший способ решить эту.

enter image description here

+29
Lucan 21 февр. 2019 г., 05:06:41

Показать вопросы с тегом